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Installation Guide: SIL Hebrew Font System

Introduction

The enclosed files constitute the SIL Hebrew Font system. The Summer Institute of

Linguistics (SIL) is an organization of linguists dedicated to the study and promo-

tion of the thousands of languages around the world. The International Publishing

Services department serves SIL by developing products to assist in the publication

of linguistic texts. We are happy to make these Hebrew fonts available to the gen-

eral public at no charge. You may (and are encouraged to) share these fonts with

your friends and co-workers, but with the following restrictions:

1 . All files must be copied together, including this one.

2 . No fee may be charged for the fonts

3 . They may not be used as a basis for other fonts.

Even though these fonts are “free”, SIL retains all copyright and ownership of the

included fonts and reserves the right to restrict their use and distribution at any

time. They may be placed on bulletin boards, etc. but cannot be included in (or

bundled with) any commercial product including hard disks or CD-ROMs without

specific written permission.

The SIL Ezra font contains all the symbols used in Biblical Hebrew and is supplied

in Regular. The SIL Hebrew Transliteration fonts are supplied in Regular, Italic,

Bold, and Bold-Italic styles. The SIL Hebrew Transliteration Caps fonts are sup-

plied in Regular, Italic, Bold, and Bold-Italic styles.

In addition to the fonts themselves, this package includes the Tavultesoft Key-

board Manager™ (KeyMan), a Windows keyboard enhancer. The KeyMan key-

board file which is included simplifies the typing of Hebrew text. For Macintosh

users, this package includes SILKey, a Macintosh keyboard enhancer and a SILKey

keyboard file for Hebrew. Users may produce their own keyboard file using Key-

Man or SILKey, if desired.
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License

This is a legal agreement between you and the Summer Institute of Linguistics,

Inc. (SIL) covering your use of the SIL Hebrew Font System. Be sure to read the

following agreement before using the software. IF YOU DO NOT AGREE TO

THE TERMS OF THIS AGREEMENT, DO NOT USE THE SOFTWARE AND

DESTROY ALL COPIES OF IT.

This copyright software is distributed as freeware. You may use this software

without any charge and may distribute to others. The software is owned by SIL

and is protected by United States copyright laws and international treaty provi-

sions. Therefore, you must treat the software like any other copyrighted material

(e.g. a book or musical recording).

Commercial distribution of the software is restricted without permission of SIL. If

you wish to distribute this software contact SIL for details on obtaining a license.

You may not rent or lease the software, nor may you modify, adapt, translate, re-

verse engineer, decompile, or disassemble the software.

If you violate any part of this agreement, your right to use this software terminates

automatically and you then must destroy all copies of this software in your posses-

sion.

THE SOFTWARE AND RELATED DOCUMENTATION ARE PROVIDED “AS

IS” AND WITHOUT WARRANTY OF ANY KIND AND SIL EXPRESSLY

DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IMPLIED,

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

UNDER NO CIRCUMSTANCES SHALL SIL BE LIABLE FOR ANY

INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT

FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED

DOCUMENTATION, EVEN IF SIL HAS BEEN ADVISED OF THE

POSSIBILITY OF SUCH DAMAGES.

This Agreement shall be governed by the laws of the State of Texas. If for any rea-

son a court of competent jurisdiction finds any provision of this Agreement, or

portion thereof, to be unenforceable, that provision of the Agreement shall be en-

forced to the maximum extent permissible so as to effect the intent of the parties,

and the remainder of this Agreement shall continue in full force and effect.

The software and documentation is provided with RESTRICTED RIGHTS.

Use, duplication, or disclosure by the Government is subject to restrictions as set

forth in subdivision (b)(3)(ii) of The Rights in Technical Data and Computer

Software clause at 252.227-7013.

Manufacturer is the Summer Institute of Linguistics, 7500 West Camp Wisdom

Rd., Dallas, Texas, 75236, United States of America.
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QuickStart

Follow the instructions for installation of fonts and keyboards below. Try out the

fonts in a number of your favorite applications. Should you decide to use the fonts

extensively or for large texts, we recommend you read the Technical Documenta-

tion.

Installation in Microsoft Windows

Installation of the SIL Hebrew font system in Windows requires two separate tasks.

The first is to install the fonts themselves, and the second is to install KeyMan.

Windows Font Installation

The SIL Hebrew TrueType fonts for Windows can be installed just like any other

TrueType font. You may use any font installer programs you have, or the Control

Panel application supplied with Windows.

Note: If you have previous versions of the SIL Hebrew fonts on your system, you

must remove them (using the Control Panel application) before trying to install

the new fonts.

Font installation using the Control Panel is described in Chapter 5 of your Micro-

soft Windows User’s Guide, and summarized below.

1 . Insert the SIL Hebrew Fonts distribution disk into your computer disk drive.

2 . Using Program Manager, launch the Control Panel application (normally

found in the Main group).

3 . Once the Control Panel is running, double-click on the Fonts icon to bring up

the Fonts dialog.

4 . Click on the Add... button to bring up the Add Fonts dialog.

5 . Open the Drives list and select the drive that contains the floppy. In a few sec-

onds the names of the SIL Hebrew fonts will appear in the List of Fonts.

6 . Click on Select All and then on OK. In a few seconds, the SIL Hebrew fonts will

be listed in the Installed Fonts list.

7 . Click on Close.

8 . Close the Control Panel application.

Note that certain applications may not see the new fonts immediately. You may

have to quit and restart the application for the fonts to become available.

KeyMan Installation

The Tavultesoft Keyboard Manager, or KeyMan, is a program that enables you to

easily type non-English text in any Windows application. This package contains

KeyMan and a control file that defines an Ezra Hebrew keyboard. Used together,
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KeyMan and the SIL Hebrew fonts provide an easy method for creating and edit-

ing documents that contain Hebrew text. These keyboards will provide the best

viewing and printing of Hebrew texts. If you also require searchability, you will

need to install additional keyboards. Please see the Technical Documentation.

The KeyMan program has its own SETUP program that works like the SETUP pro-

gram of many other Windows applications. To install KeyMan, insert the KeyMan

disk into your disk drive and perform the following steps:

1 . If you have downloaded KeyMan from the Internet, using the File Manager,

create a new directory for the km32.exe file. Place a copy of the file in the new

directory. Select the File/Run menu item on the Program Manager. Use

Browse to select the file “km32.exe”. This will expand the files needed for

KeyMan.

2 . Select the File/Run menu item on the Program Manager. Select BROWSE

again and select “SETUP.EXE” from the installation diskette or the new di-

rectory created above. Press OK twice.

3 . When prompted, enter the name of the directory where you want KeyMan in-

stalled. Click Continue.

4 . After the installation completes, click Okay.

5 . KeyMan is now installed and will automatically launch the next time you start

Windows. You can use the File Manager to delete the new directory contain-

ing the km32.exe file and its uncompressed contents, if you wish. Now use File

Manager to copy the keyboard files to the same directory where you’ve just

installed (not uncompressed) KeyMan. Copy all files ending in .kmn and all

files ending in .bmp. (Highlight the names and press Ctrl while dragging to

copy.)

6 . Close File Manager, locate the Tavultesoft group, and double-click the Key-

Man icon. You may have to double-click it twice to get the screen.

7 . After the flash-screen displays, when the KeyMan screen appears, click Op-

tions, then HotKeys... and change the second hotkey from Alt to CTRL. Be

sure to click on both the CTRL box and the Alt box. This will prevent a con-

flict with a key defined on the Ezra keyboard. Click Ok.

8 . Click the Load button. Check that the current directory is the new one where

KeyMan was just installed. The available keyboards found in the KeyMan di-

rectory will display. Click on the SIL Ezra Display keyboard and click Okay.

Click Load again, select the SIL Hebrew Trans Display keyboard and click

Okay. Now click Close or Okay.

9 . Click outside the KeyMan screen and it will disappear.

The KeyMan and keyboards installation is now complete.

Once KeyMan is running properly, you will see two new buttons attached to the

left end of the title bar of the active window on your screen. The buttons, which

looks like this  and  indicate that the Ezra Hebrew keyboard and Hebrew

Transliteration keyboard are loaded but not active. To activate the Hebrew key-
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board, click the button and it will turn to , indicating that the Ezra Hebrew key-

board is active. To activate the transliteration keyboard, click the button and it will

turn to , indicating that the Hebrew Transliteration keyboard is active. Be

sure to change the font to SIL Ezra or SIL Heb Trans before starting to type. This

won’t happen automatically.

If you need more information, run the KEYMAN.HLP file that was installed on

your hard drive with the program.

If you already have the current KeyMan version installed, you need only do Steps

5 through 9 above.

Installation on a Macintosh

Installation of the SIL Hebrew font system for Macintosh requires two separate

tasks. The first is to install the fonts themselves, and the second is to install SILKey

and the SILKey Ezra and Hebrew Transliteration keyboards.

Macintosh Font Installation

The SIL Hebrew fonts for Macintosh can be installed just like any other TrueType

font.

Note: If you have previous versions of the SIL Hebrew fonts on your system, you

must remove them (by dragging them to the Trash from your System/Fonts

Folder) before trying to install the new fonts.

Font installation is summarized below.

1 . If you are installing from disk, insert the SIL Hebrew Fonts distribution disk

into your computer disk drive.

2 . Double-click the disk icon to see the contents.

3 . Select and drag the one .suit file and two .fam files to your System Folder.

4 . When it asks whether you want the fonts placed in the Fonts folder, click

‘Okay’.

Note that certain applications may not see the new fonts immediately. You may

have to quit and restart the application for the fonts to become available.

Macintosh GX Font Installation

If you are running GX on your Macintosh and you have an application to use that

is GX-aware, you will probably prefer to use the GX versions of the SIL Hebrew

fonts. The SIL Hebrew GX fonts for Macintosh can be installed just like any other

TrueType font.

Note: If you have previous versions of the SIL Hebrew GX fonts on your system,

you must remove them (by dragging them to the Trash from your System/Fonts

Folder) before trying to install the new fonts.
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Font installation is summarized below.

1 . If you are installing from disk, insert the SIL Hebrew Fonts distribution disk

into your computer disk drive.

2 . Double-click the disk icon to see the contents.

3 . Select and drag the one GX .suit file and one GX .fam files to your System

Folder.

4 . When it asks whether you want the fonts placed in the Fonts folder, click

‘Okay’.

Note that certain applications may not see the new fonts immediately. You may

have to quit and restart the application for the fonts to become available. You may

also install the non-GX versions of our fonts without worrying about conflicts.

SILKey Installation

The SILKey Keyboard Manager is a program that enables you to easily type non-

English text in any Macintosh application. This package contains SILKey and a

control file that defines a Hebrew and transliteration keyboard. Used together,

SILKey and the SIL Hebrew fonts provide an easy method for creating and editing

documents that contain Biblical Hebrew text.

To install SILKey, perform the following steps:

1 . If you are not installing from disk, double-click the SILKEY.sea file.

2 . Drag the “SILKey Extension” file to the icon of your (closed) System Folder.

The Finder should automatically put it in the Extensions folder.

3 . Drag the “SILKey” application program file to any convenient location on

your hard disk (for example, an Applications or Utilities folder).

4 . Restart your Macintosh, in order to activate the SILKey Extension (which will

activate during the restart).

SILKey Keyboard Installation

Follow this procedure to install the SILKey keyboards:

1 . From the SIL Hebrew Fonts distribution disk, select and drag the SILKey

Ezra-DE and Heb Trans-DE keyboard files to any convenient location on

your hard disk. These keyboards will provide the best viewing and printing of

Hebrew texts. If you are using GX, you will need to use the Ezra-SE and Heb

Trans-SE keyboards. They will provide excellent viewing, printing, and

searchability.

2 . If you are installing from disk, you are now done with it. Drag the disk icon to

the trash and remove the disk from your machine.

Installation is now complete. These procedures should not have to be repeated.
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Typing using a SILKey keyboard

1 . Find and double-click the SILKey application icon which you installed in Step

2 of SILKey Installation above.

2 . Click Install... in the SILKey:Loaded Keyboards window.

3 . Find and Open (or double-click) the desired keyboard file. It is now active.

Click in your application and begin typing. (Don’t forget to change the font!)

If you do not wish to type Hebrew text immediately, you should de-activate it

by clicking the small keyboard icon next to it. You may install more than one

keyboard, but only one can be active at a time.

4 . When you are done typing, go back to SILKey and either quit, or de-activate

the keyboard.

Ezra Hebrew Symbols

For layout of the SIL Hebrew fonts, see the full technical documentation.

For the most part, the Hebrew symbols are arranged in a logical order, attempting

to match the Hebrew symbols to the approximate equivalents in a standard Win-

dows font. Certain character locations (specifically 127 and 160) have special

meanings to some applications and therefore have not been used for Hebrew

symbols. All other locations above 31 have been used.

Typing in Hebrew

With the KeyMan or SILKey keyboard enabled, you can type Hebrew codes by

simply typing the equivalent roman symbols. For example, if you were to type “e”

for segol, your application would receive the character whose decimal code is 101,

198, 213 or 229. KeyMan automatically selects the appropriate overstriking segol

based on the preceding consonant.

Word-final ª, £, ¤, ¥, ¦ are also handled specially: for example, the symbol n is

converted to ¤ instead of n when it is at the end of a word.

Neither the keyboard nor the fonts can handle changing the directionality of the

text. This must be handled either by the application or the operating system. A

simple macro for use in Microsoft Word 6 is included for reversing text. The in-

structions for use are below. Also see the technical documentation for information

about batch processing using CC and more about Macintosh GX fonts.

Please note: KeyMan and SILKey work by watching what keys are pressed in what

order. For this reason, when you are editing a document you may find that in-

serting characters into existing text does not do what you expect. In this case, you

should remember to type the equivalent of the entire word, if necessary.
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Typing Right-to-Left

A macro called “ReverseText” has been included for Microsoft Word 6 users. This

is a small program whose function is just to reverse the order of any selected text.

The idea is to type your text in Hebrew in the order in which it is pronounced. It

will appear on the screen in left-to-right order. Select the text and run “Reverse”.

This will place the Hebrew text (or any text) in right-to-left order. Working in

conjunction with KeyMan or SILKey, the end result is Hebrew text in correct or-

der with correctly placed points. This is offered for users of Word 6, which does

not handle right-to-left texts.

Installation of “ReverseText” in Microsoft Word

To install the macro “ReverseText”, follow these instructions. You will only need

to do this one time.

1 . Have the SIL Hebrew Fonts package available either on diskette or on your

hard drive.

2 . Go into Word 6.

3 . Be sure all files are closed.

4 . Click File>Open

Select “Document Templates” under List Files of Type:.

5 . Select “reverse.dot” from the SIL Hebrew Fonts package diskette or from its

location on your hard drive.

6 . A copy of these instructions should appear on the screen.

7 . Click Tools>Macro...

At the bottom of the box, under the heading “Macros Available in”, check that

“All Active Templates” or “Reverse.Dot” (Template) is listed.

8 . Click so that ReverseText is in the selection box.

9 . Click Organizer.

1 0 . Highlight ReverseText by clicking it. Check that “To Normal:” is at the upper

right of the box.

1 1 . Click Copy>>. This will copy the name “ReverseText” to the Normal side.

Click Close (not Close File).

1 2 . Click File>Save All.

1 3 . Click File>Close to close Reverse.Dot. This will save a copy of ReverseText in

your Normal template, and make it available for use.

Using ReverseText

Using the KeyMan Hebrew keyboard and SIL Ezra font, type a word or line of text

in normal order, that is, in the order it is pronounced. Select the text so that it is

highlighted. Click Tools>Macro>. Highlight “ReverseText” and click Run.
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The highlighted text will reverse direction. If you have selected a line of text, the

first word will now be at the end of the line. The order of letters in each word will

also be reversed.

You will probably wish to install a button on your Toolbar for easier access to Re-

verseText. See your Microsoft Word manual for directions for this simple proce-

dure. It may be listed under “Tools” or “Customizing Menus”.

Technical Support

If you have problems using the SIL Hebrew Font system, please contact:

User Support

SIL International Publishing Services

7500 W. Camp Wisdom Rd.

Dallas, TX 75236

USA

Phone: (972) 708-7495

FAX: (972) 708-7388

E-mail: fonts@sil.org


